We are aware that some users are experiencing difficulties with the auto patching system.In order to fix this issue, we strongly recommend that you follow the steps below: How to update your game (all versions) to the 2.1.0 version: Uplay version If you are not at v1.8.0 or v2.0.0, you may need to launch the game a few more times, until you are updated to the correct version.4.The Steamworks SDK introduced breaking changes to the Steam Controller API after version v1.32 so Epic's provided plugin will fail to compile.

problems updating steam platform-15problems updating steam platform-68

Before trying yo update, you should determine your current version of the Steam SDK you are already using and consider if you need to update at all. This folder name is indicative of the Steam SDK version you are running.

At the time of this writing, UE4 4.11 uses version v1.32, and the current version of the Steam SDK is v1.36.

Epic's 4.16 version of UE4 has had its Steam SDK upgraded to v1.39.

This is still one version short of the latest SDK (v1.40) at the time of this writing but its significantly more recent. I'm not sure how relevant the original post is now.

We will need to make a change inside this file to tell UE4 to use the newer version of the Steam SDK rather than the current one.

Near the top of the file, you should see lines that read similar to: Provided that no breaking API changes were made, these are all the changes required to update the Steamworks SDK.

If you have downloaded & installed your game from a digital installer (Uplay Shop, non-Steam digital retailer, etc), you have to download the Digital one.

If you have installed your game from a disc, you need to install the Retail patch.

You should be able to regenerate your Engine solution, compile your projects, and run game builds with Steam loading your new SDK version without issue.

At the time of this writing however, if you are performing an update from v1.32 to a newer version on 4.11 or older, you will encounter many errors related to the module.

If you receive a Shades of Darkness is not installed message when trying to update, please follow this procedure: If your game is on the 1.8 version and you can't install the v2.1 patch because of this error, you may have downloaded the wrong patch.