Thank you for helping, Dan Hello Dan H_44, Installation again fails on accessing: C:\Program Data\Microsoft\Windows\Start Menu\Programs\AVG 2011Make sure that hidden files and folders are displayed as described in - How To Display Hidden Files And Folders.

Please proceed with manual update of Link Scanner database as per this post. I tried to uninstall avg and got the message: Updating in progress.

If that does not help, please perform full reinstallation as described. Running update must be finished before starting installation ... I removed old installations as directed and tried (twice) to install the new. Dan Hello Dusan, I couldn't reply below - perhaps nested too deep?

I accept, but then I get a "Update failed- General Error" message. Here are the log files: Hello Zuler C,analysis of the provided update log files revealed that a AVG registry entry has been damaged which is preventing AVG update to be installed.

Windows 7 Home Premium (64-bit)Virus DB: 1435/3500I just use the Windows firewall. This situation is different than the one described in this thread originally even though the "general error" is reported in both cases.

is there anyone who can help me get my icons back Pleeeeeeeeeeez! Your fix works, however the loss of the icons continues intermittently on subsequent bootups. Your tray icons will appear each and every bootup without failure. I am a novice and I was able to do this fix based off these instructions.

Run (or Windows-key R), type in regedit and hit OK. Navigate to the key HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\Current Version\Tray Notify. Delete the values Icon Streams and Past Icons Stream. Open up the Task Manager (Ctrl Shift Esc), go to the Processes tab, select and click End Process. Open the Applications tab and click New Task at the bottom-right of the window. In the message box that pops up type in and hit OK. will reload, and the missing icons should now be back in the system-tray where they belong. Then if the volume bar isn't there, go to taskbar properties (where the volume was gray) and simply tick the box. Thanks for helping, Dan Hello Dusan, I changed the permissions on that folders as directed, but the install still fails.Error message was slightly different this time (525 vs 517): Error code: 0x C0070643Error msg: General Internal Error Additional msg: 0x C00705Context: MSI action failed I saved the log files and AVGInst at (msinfo from last night is still there): 105The folders/files that were in use and couldn't be deleted were on the tree:\Users\All Users\AVG10 ...Should the installation still fail even with fixed permissions, provide us with new installation log files.Thank you Context: MSI action failed I saved the log files and AVGInst at: 105msinfo from last night is still there The folders/files that were in use and couldn't be deleted were on the tree:\Users\All Users\AVG10 ...I have since come to realize that this is in use because it holds the scan data for the drive from the working AVG instance from another leg of my dual boot.